Lightroom 6 - Adobe Drops OS Requirements

Discussion in 'Post Processing' started by AKPHOTO, Jan 22, 2015.

  1. AKPHOTO

    AKPHOTO Administrator Staff Member

    Joined:
    Jan 13, 2015
    Messages:
    17
    Likes Received:
    1
    While not as good as a release date, Adobe is clearly making strides on the next version of Lightroom (v6.0), as they just released OS requirements for the upcoming release!

    Check out the text from the Adobe blog:

    Link to source: https://blogs.adobe.com/lightroomjo...os-support-for-next-version-of-lightroom.html
     

Share This Page